pythonのpygooglenewsをinstallするためのメモ

Pocket

pygooglenewsを普通にインストールするとエラーになる。

具体的には、feedparserのverionの指定が厳しくmacに入ってるpython3.9だと新しすぎるから。

じゃあfeedparserのdowngradeすればよいかというとそれだけじゃなくていろいろ手続きが他にもあったのでまとめておく。

まずは、setuptoolsをダウングレードする。

 pip install “setuptools<58”   

その後、condaのcliをインストールする。

“conda-repo-cli==1.0.4”

そうしてようやくfeeparserがダウングレードできる。

pip install -U –no-deps “feedparser==5.2.1”

にてようやくインストール、動作ができるようになる。

pip install pygooglenews

しかしfeedparserのlibrary部分でエラーがでるので、美しくはないが、

libraryを直接編集する。

feedparser.pyを

_base64decode = getattr(base64, 'decodebytes', base64.b64decode)

に変更する。
もとは、
    # _base64decode = getattr(base64, 'decodebytes', base64.decodestring)

コメントを残す